Please visit our new community...

Bug mkv audio not in sync with video

 
  • Created:over 3 years ago
  • Modified:over 3 years ago by birkoff
  • Status:invalid
  • Related:#3679 , #3795
no supporters

I have noticed with my blu-ray rips that my audio is ahead of the video by about 3 seconds. This does not happen in WMP. Also, I'll start the file in MB, pause it, then back out to WMC (exit MB), and go to the now playing tab. If I play the file from there, everything is in sync. So somehow the problem lays with MB. Can anyone help me out with this?

 
votes newest oldest
 
  • Created:over 3 years ago

Could this be CPU related? What amount of CPU is ehexthost using when this happens?

What spec machine are you running? What version of windows?

 
  • I don’t think so. As I said it is only in MB. The files play fine in WMP, WMC, and MPC-HC. I am running an Atom 330 (ASUS AT3N7A-I). Total CPU usage is about 20% when playing in MB. I am running Windows 7 x64. – VanillaXtract over 3 years ago
 
  • Created:over 3 years ago

Anyone have any ideas?

 
 
  • Created:over 3 years ago

WMC uses differnt codecs that WMP – i would certainly make sure you are convinced it is not a codec issue :–)

 
  • Thank you for your input. However if you read my originaly post, it states that the files play fine in WMC and WMP. The only time I have an issue is using MB in WMC. If I play the file in WMC without using MB, it plays just fine. – VanillaXtract over 3 years ago
 
  • Created:over 3 years ago

Same problem I have a blue ray rip of a movie in mkv format at 1080p and the audio is ahead of the video and the video is choppy

 
  • when you play from WMCs video library as well? – sam over 3 years ago
  • Viper, are you using the Ion chipset as well? This problem did not occur for me until I switched to it. – VanillaXtract over 3 years ago
  • It is happening on two of my machines.. a Core2Duo on my laptop, and on my pvr which is a dual core pentium 4, the video cards on both are nvidia 8500 and nvidia 9600 respectively.. – Viper over 3 years ago
  • I already tried reinstalling once, but I may as well try again. There is nothing in common with our systems. My Ion has the problem whereas my Core2Duo with an ATI 4350 works perfectly. – VanillaXtract over 3 years ago
 
  • Created:over 3 years ago

I forgot to mention that this started when I switched to the Ion platform. This problem did not happen for me when I was running a Core2Duo. This has also occurred with various codecs (ffdshow DXVA, MPC-HC DXVA, and CoreAVC).

 
 
  • Created:over 3 years ago

any ideas on how to fix this?

 
 
  • Created:over 3 years ago

I can only offer some troubleshooting and it’s a bit involved, but could possibly narrow it down. If you would like to try, do the following:

  1. Emtpy cache completely
  2. Clear all virtual folders (media locations) in the Configurator
  3. Move a problematic file to a location where it is the ONLY title
  4. Add the location of the title as a new media location in the Configurator
  5. Start up Media Browser and allow it to pull the metadata/images for that title.
  6. Once info is complete, play the movie and report back if there is any stuttering/sync issue.
 
 
  • Created:over 3 years ago

Are your titles stored externally? The reason I ask is this topic and this one may provide you with some answers depending of your setup.

 
 
  • Created:over 3 years ago

Yes skynet I have my files stored on a WHS. I will try some of the suggestions when I get home from work.

My problem is a little different than yours in that the video plays smoothly, it’s just a sync problem. And I have some blu-ray rips in m2ts that play with no problem, it’s only HD mkv’s that have issues.

But some of the stuff in your posts sound like it could be related to mine. Since I am running an Ion platform, anything extra going on while a HD movie is playing is likely to cause problems. Thank you for the help and hopefully it will work for me.

 
 
  • Created:over 3 years ago

So I disabled offline files and it has helped. I put a HD mkv on my HTPC as well. That file played perfectly and the mkv’s on my server now play fine. If I skip ahead it takes a minute or so for everything to get back in line, but eventually it does. Still not perfect like it used to be, but a heck of a lot closer than before. Thank you for the help and I hope we can figure this out completely.

 
 
  • Created:over 3 years ago

1080 P played great in windows media player, but stuttery in windows media center argh

 
  • yeah probably an x64 codec issue :( – sam over 3 years ago
 
  • Created:over 3 years ago

@Viper – I had issues when running things in WMC but they worked fine in WMP… Are you running an x64 version of Windows? If so, by default, when you run WMP, it runs the 32bit version of the app… You need to think of the 32 bit and 64 bit versions as basically completely separate apps… WMC on a 64 bit machine, by default, will run in 64 bit mode…

Try running the videos that are having issues in 64 bit version of WMP, and see if the same problem occurs…

This of course doesnt have anything to do with MB, but at least it might help narrow the problem down a little more…

 
 
  • Created:over 3 years ago

Viper, what is your HTPC hardware? The only way I got mine to play smoothly on my Ion/Atom setup was to use CoreAVC with CUDA. All DXVA codecs were choppy in 64bit apps even with CPU usage at about 25%.

 
 
  • Created:over 3 years ago

Issue resolved. I had a single stick of 2GB ram. I added a second stick to activate the dual channel and it resolved the issue for some reason.

 
  • Wow nice find. Thanks for letting us know. – skynet600 over 3 years ago