Please visit our new community...

Question Commandline service refresh not working

 
  • Created:over 2 years ago
  • Status:open

I run the service refresh each time my machines wake from standby automaticly with this command-line.

“Start C:\Progra~2\MediaBrowser\MediaBrowser\MediaBrowserService.exe /refresh”

I do this because I think one service refresh on a day is not enough.

This command-line has always worked and still does but on one pc it is no longer working. I need to kill the service first and then the command-line does work again.

What could be the cause of that?

 

1 Answer

votes newest oldest
 
  • Created:over 2 years ago

I’m not sure but running a refresh right when you start up like this is generally a bad idea. In fact we removed logic such as this from the service to be sure a refresh wouldn’t kick off on a start up.

This is going to put too much concurrent load on the machine and the DB right when you are first starting up MB and that will more than likely cause performance issues.

 
  • okay, I have turned auto refresh off and have made an scheduled task that runs a few times on a day on the moments nobody is home. Still I like to know why I have to kill the service first before it will refresh on that one pc. – heula over 2 years ago
  • Probably a network or security issue. I saw in your other logs an error saying the network could not be found when we were trying to communicate with the service. Make sure you have the network and netbios enabled on that machine. – ebr over 2 years ago
  • The server is on and the netbios is enabled. – heula over 2 years ago
  • It is actually trying to communicate with a process on the same machine. Do you have a firewall or other malware protection that might be blocking it? Or is that machine running under a user other than admin? – ebr over 2 years ago
  • When I right click and click refresh now it’s refreshing just fine but when I run the command-line it does nothing on only one machine. The same command-line runs just fine on the other 2 – heula over 2 years ago
  • show 2 more comments